e-Babillard - plateforme pédagogique interactive
Pensez à mettre un avatar personnel Bienvenue, Invité. Veuillez vous connecter ou vous enregistrer.
20 Octobre 2018 à 00:24:23

Connexion avec identifiant, mot de passe et durée de la session
Recherche:     Recherche +
* Flux RSS www.jpdelx.com Accueil Aide Identifiez-vous Enregistrez-vous
+  e-Babillard - plateforme pédagogique interactive
|-+  Ressources pédagogiques communes concernant...
| |-+  EXCEL
| | |-+  Sujet: [EXCEL] Tests de validité ?
« sujet précédent | | sujet suivant »
Pages: [1] Imprimer
Auteur Sujet: [EXCEL] Tests de validité ?  (Lu 881 fois)
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Tests de validité ?
« le: 11 Novembre 2008 à 07:52:13 »

Bonjour

/!\ notion très importante /!\

Il s'agit d'utiliser la fonction logique SI() afin d'afficher
le résultat d'un calcul uniquement dans le cas où il doit
être réalisé.

On peut utiliser la syntaxe suivante : SI(cellule="";"";formule de calcul)
"" indique RIEN.





Il est aussi possible d'utiliser une des fonctions EST() -> aide. En particulier ESTVIDE(cellule).

@lpf




* excel_fonctions_est.pdf (15.86 KB - Téléchargé 16 fois.)
Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Fonctions ESTVIDE() & ESTNUM() -> animation
« Répondre #1 le: 16 Novembre 2008 à 16:05:28 »

Bonjour

Voir cet exemple animé ( FLASH - 1 Mo ).
Click à droite sur le lien et Enregistrer la cible sous...

Vous pouvez gérer la lecture de l'animation à l'aide de la barre de contrôle en bas de l'écran.



Le tableau EXCEL est en PJ.

@lpf


* estvide.xls (13.5 KB - Téléchargé 32 fois.)
* estvide_estnum.jpg (115.01 KB - Téléchargé 567 fois.)
Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
hln_90
Invité


Courriel
[EXCEL] Tests de validité ?
« Répondre #2 le: 14 Mars 2009 à 16:39:46 »

bonjour voila je ne comprend pas ceci,
dans la fiche 4 l'exercice 9 il y a l'animation mais lorsqu'il est mis en formule
G4<>'' ''
je ne comprend pas a quoi ceci correspond
enfin j'ai compris que cela signifiait :qu'il y avait dans la cellule G4 une écriture et donc que cela a été réglé. mais les signes en eux-même je ne les comprend pas
pourquoi <>?

merci d'avance.
Journalisée
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Tests de validité ?
« Répondre #3 le: 14 Mars 2009 à 17:06:43 »

Bonjour Hélène

Citation de: hln_90
...
dans la fiche 4 l'exercice 9 il y a l'animation mais lorsqu'il est mis en formule
G4<>'' ''
...
mais les signes en eux-même je ne les comprend pas pourquoi <>?
...

Il s'agit de l'opérateur de comparaison "différent de".

SI(G4<>"";...;...)  signifie donc "si la cellule G4 n'est pas vide alors...".

Tu peux trouver des éléments de réponse supplémentaires via l'aide d'EXCEL
et dans le support de cours : http://jpdelx.club.fr/excel_si.pdf

Voici 4 formules identiques :

Code:
=SI(A1<>"";"pas vide";"vide")
=SI(A1="";"vide";"pas vide")
=SI(ESTVIDE(A1);"vide";"pas vide")
=SI(NON(ESTVIDE(A1));"pas vide";"vide")

<a href="http://jpdelx2009.free.fr/vide_pas_vide.swf" target="_blank">http://jpdelx2009.free.fr/vide_pas_vide.swf</a>

@lpf


* compagnon office.jpg (94.45 KB - Téléchargé 453 fois.)
* EXCEL - opérateurs SI.jpg (88.01 KB - Téléchargé 409 fois.)
Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
hln_90
Invité


Courriel
[EXCEL] Tests de validité ?
« Répondre #4 le: 14 Mars 2009 à 21:39:37 »

merci de m'avoir éclairci sur ce sujet.
Journalisée
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Tests de validité ?
« Répondre #5 le: 15 Mars 2009 à 10:00:59 »

Bonjour Hélène

Citation de: hln_90
merci de m'avoir éclairci sur ce sujet.

Parfaitement normal de mon côté  Smiley

L'interactivité est un des points majeurs de la pédagogie active que j'utilise  Wink

@lpf
Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
Cécé
Invité


Courriel
[EXCEL] Tests de validité ?
« Répondre #6 le: 15 Mars 2009 à 20:46:51 »

Bonsoir   Smiley

concernant ceci :

Voici 4 formules identiques :


Code:
=SI(A1<>"";"pas vide";"vide")
=SI(A1="";"vide";"pas vide")
=SI(ESTVIDE(A1);"vide";"pas vide")
=SI(NON(ESTVIDE(A1));"pas vide";"vide")


y a-t-il dans certains cas une formule plus adapetée que les autres ou les 4 formules permettent- elles d'arriver au même résultat dans n'importe quel cas ?
Journalisée
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Tests de validité ?
« Répondre #7 le: 15 Mars 2009 à 21:01:20 »

Cédric

Citation de: Cécé
...
y a-t-il dans certains cas une formule plus adapetée que les autres ou les 4 formules permettent- elles
d'arriver au même résultat dans n'importe quel cas ?

Comme tu as pu le constater par toi même ( cf. animation ), elles donnent exactement le même résultat.

Pour l'instant, à votre niveau, il n'y a pas de formule "meilleure" qu'une autre. Il faut
avant tout qu'elle fonctionne dans tous les cas.

@lpf
Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
jpdelx
Administrator
Hero Member
*****
Hors ligne Hors ligne

Sexe: Homme
Messages: 12767


Il n'y a pas de questions idiotes...


WWW
[EXCEL] Tests de validité ?
« Répondre #8 le: 05 Octobre 2011 à 07:05:28 »

Journalisée

J.Phil. DELCROIX
www.jpdelx.com

Merci de rédiger vos messages dans un français compréhensible par tous !
Pages: [1] Imprimer 
e-Babillard - plateforme pédagogique interactive  |  Ressources pédagogiques communes concernant...  |  EXCEL  |  Sujet: [EXCEL] Tests de validité ? « sujet précédent | | sujet suivant »
Aller à:  

Propulsé par MySQL Propulsé par PHP e-Babillard - plateforme pédagogique interactive | Propulsé par SMF 1.0.6 modifié par jpdelx.
© 2001-2005, Lewis Media. Tous droits réservés.
XHTML 1.0 Transitionnel valide ! CSS valide !
Page générée en 0.734 secondes avec 20 requêtes.